解决ORACLE ORA-201和ORA-202 错误

如果自己搞不定可以找诗檀软件专业ORACLE数据库修复团队成员帮您恢复!

诗檀软件专业数据库修复团队

服务热线 : 13764045638 QQ号:47079569 邮箱:service@parnassusdata.com

 

适用于

Oracle 数据库 – 企业版 – 9.2.0.1到11.2.0.3版本 [Release 9.2 to 11.2]
本文档的内容适用于各个平台

目的

这个文档的目的是描述当你接收到如下报错时该如何考虑。

– ORA-201: 控制文件版本和数据库版本不兼容

– ORA-202: 控制文件: <name>

解决步骤

产生ORA-201和ORA-202错误:

  • 你尝试给COMPATIBLE设置一个错误的值;
  • 执行一个和当前COMPATIBLE参数值不兼容的操作

使用COMPATIBLE参数的意义:

  • COMPATIBLE允许你使用一个新的版本,而在同一时间以确保较早版本的向后兼容性。这对如果有必要恢复到早期版本是有帮助的。
  • 同时允许你使用一些较新版本的新特性。尝试使用新的特性需要兼容性把值设置成高版本会返回错误。

一些要求和限制能帮你避免ORA-201或ORA-202错误:

1. 在升级/降级:

  • 从9.2.0.X升级到11g强可以制把COMPATIBLE参数最少设置成10.1.0.当升级完成后,如果有必要,可以根据需求进一步增加;
  • 从10.1.0.X或10.2.0.X升级到11g,你可以把COMPATIBLE设置成当前值直到升级成功完成;
  • 从11g 降级到9iR2是不支持的。这是因为升级过程中COMPATIBLE参数设置为最低10.1.0。

2. 在创建数据库:

  • 11.2版本, COMPATIBLE 参数默认11.2.0. 最低10.0.0.
  • 11.1版本, COMPATIBLE 参数默认11.1.0. 最低10.0.0.
  • 10.2版本, COMPATIBLE 参数默认10.2.0. 最低9.2.0.
  • 10.1版本, COMPATIBLE 参数默认10.0.0. 最低9.2.0.
  • 9.2版本, COMPATIBLE 参数默认8.1.0. 值为8.1.0到当前版本之间.

注释:
10.1-11.2,当你创建数据库是使用默认值,你可以理解使用所有的新性能,永远不能降级数据库.

需要注意的是一个新的数据库实际上从未被降级,因为你只能降级到你升级前的最后一个版本。

3. 当你降低COMPATIBLE的值:

  • 用较低的COMPATIBLE的值时你无法打开数据库,除非你从备份里进行还原。这是因为数据文件头包含COMPATIBLE参数信息。如果这个参数增长了且数据库已经重启,那么文件头部会修改成高的版本.如果你想降低这个参数值,就会报ORA-201或ORA-202错误。
  • 设定COMPATIBLE值时考虑默认值设定比特定的补丁急低,比如考虑10.2.0低于10.2.0.1,1.02.0.2.

遇到ORA-201/ORA-202错误怎么做?

注释:如同所有的破坏性操作,取决于你从下面考虑解决方案,Oracle公司强烈建议执行这些操作之前采取数据库的完整冷备份。

  1. 设置一个合适的COMPATIBLE初始参数.
  2. 如果你的数据库设compatible=9.2.0,那么你可以降级从 10.x 到9.2.0.1.0. 如果你的数据库设定compatible=10.1.0, 那么你可以降级到 10.1.0.2.0 (10g的初始版本 ).
  3. 如果你需要设置一个较低的COMPATIBLE,你可以恢复到恢复到值增长之前的那个时间点.
  4. 重建控制文件,设置compatible的值为需要的版本。

他需要关注的:

  • 避免发生这种错误在RAC下,各个节点的COMPATIBLE 参数值设定一样;
  • 避免发生这种错误在备库上,主库和备库的COMPATIBLE 参数值设定一样

关注刘相兵的新浪微博

扫码加入微信Oracle小密圈,了解Oracle最新技术下载分享资源

Speak Your Mind

沪ICP备14014813号

沪公网安备 31010802001379号

TEL/電話+86 13764045638
Email service@parnassusdata.com
QQ 47079569