在AIX 5.3+HACMP 5.4以上环境安装10gR2 10.2.0.1 RAC CRS Clusterware必须先运行Patch 6718715中的rootpre.sh

在AIX 5.3+HACMP 5.4以上环境安装10gR2 10.2.0.1 RAC CRS Clusterware必须先运行Patch 6718715中的rootpre.sh,若不运行该rootpre.sh则会导致后续的诸多问题,例如:

 

 

1. 在 “Cluster Node Information” or “Specify Cluster Configuration” 2个界面窗口中无法点击灰色的ADD NODE按钮:

 

AIX: "Cluster Node Information" or "Specify Cluster Configuration" Window Does not Show Any Node and "Add" Button is Greyed Out

Oracle Server - Enterprise Edition - Version: 10.2.0.1 and later   [Release: 10.2 and later ]
IBM AIX on POWER Systems (64-bit)
Symptoms

Installing Oracle Clusterware (CRS or 11gR2 Grid Infrastructure), "Cluster Node Information" or "Specify Cluster Configuration" window does not show any node and "Add" button is greyed out:

Installation log

[main] [10:21:20:345] [sQueryCluster.isCluster:74]  LKMGR file =/usr/sbin/cluster/utilities/cldomain
[main] [10:21:20:346] [QueryCluster.:49]  Detected Cluster
[main] [10:21:20:346] [QueryCluster.isCluster:65]  Cluster existence check = true

Cause

The cause is IBM HACMP (or PowerHA) executable was not removed cleanly when HACMP was deinstalled. After HACMP was deinstalled, "ls" still shows one HACMP command:

$ ls -l /usr/sbin/cluster/utilities/cldomain
lrwxrwxrwx    1 root     system           29 Sep 21 13:54 /usr/sbin/cluster/utilities/cldomain -> /opt/VRTSvcs/rac/bin/cldomain

Oracle OUI depends on /usr/sbin/cluster/utilities/cldomain to determine if vendor clusterware exists, if so, it will install on top of HACMP and get list of nodes from HACMP.

In this case, since HACMP executable is detected, OUI will not allow user to manually enter node information, however, since HACMP was deinstalled, it does not have any node membership information.

Solution

The solution is to remove /usr/sbin/cluster/utilities/cldomain from all nodes and restart OUI.

 

 

 

2. 运行root.sh时显示ocrconfig.bin无法加载必要的库文件,或者干脆root.sh运行失败 ,显示Failed to start Oracle Clusterware stack;

 

由于10g CRS对于AIX HACMP有较多的依赖关系所以 随10.2.0.1附带的rootpre.sh无法有效配置oracle用户的HA信息,所以必须先下载Patch 6718715: SUPPORT FOR HACMP 5.4 IN ROOTPRE.SH SCRIPT FOR 版本10.2.0.3,否则10.2.0.1 CRS将无法正常安装。

 

 

 

 

Product : 	Oracle Database Server 10GR2 (10.2.0.x)

Bug     :       6718715 - Support HACMP 5.4

Platforms: AIX 5L (5.x), AIX 6.x

Steps to apply the patch
------------------------
1--> Login as root user 
2--> Unpack the files shipped in this patch in a temporary directory
3--> Run the rootpre.sh script
     ./rootpre.sh

Note: 
 This patch supercedes any rootpre.sh shipped with the aforementioned 
 Oracle products.

Contents of this distribution
-----------------------------
1--> README.txt
2--> loadext(32bit executable)
3--> pw-syscall32 (32-bit executable for 32-bit kernels in AIX 4.1 & AIX 4.2)
4--> pw-syscall (32-bit executable for 32-bit kernels in AIX 4.3 and AIX 5L)
5--> pw-syscall64 (64-bit executable for 64-bit kernels in AIX 5L)
6--> rootpre.sh(commands text)
7--> ORCLcluster/lib/libskgxnr.a (Oracle 64-bit cluster library)
8--> ORCLcluster/lib/libskgxnr.so (Oracle 64-bit cluster library)
9--> ORCLcluster/lib32/libskgxnr.a (Oracle 32-bit cluster library)
10--> ORCLcluster/lib32/libskgxnr.so (Oracle 32-bit cluster library)

关注dbDao.com的新浪微博

扫码关注dbDao.com 微信公众号:

Comments

  1. Software Version and other details
    AIX
    5.3 TL06 or newer (specifically bos.rte.lvm must be at least 5.3.0.60) or 6.1
    or newer
    HACMP 5.4.1 (Available in media or APAR IZ02620)
    RSCT
    RSCT (rsct.basic.rte)
    RSCT V2.4.7.3 (APAR IZ01838, this APAR is integrated into V2.4.8.1)
    Oracle
    10gR2
    Oracle 10gR2 patchset 10.2.0.3, CRS bundled < > is
    required. In addition, rootpre.sh < > is required when using
    HACMP 5.4.1 with a fresh install of Oracle RAC clusterware or when
    upgrading from Oracle 10gR1 to Oracle 10gR2. This patch should be
    installed on all nodes before installing Oracle 10.2.0.1 software. Be sure to
    download the 10gR2 version of Patch 6718715

    Software Version and other details
    AIX 5.3 TL9 or above or 6.1 TL2 SP1 or above
    HACMP 5.5 and APAR IZ43548
    RSCT For AIX 5.3, RSCT 2.4.10.0 or above. For AIX 6.1, RSCT 2.5.2 or above
    Oracle
    10gR2
    Certified with Oracle 10gR2, patchset 10.2.0.4 and bundled patchsets:
    • CRS #3, Patch 7715304
    • RAC #2, Patch:7573282
    In addition, rootpre.sh patch 6718715 is required when using PowerHA 5.5
    with a fresh install of Oracle RAC clusterware or when upgrading from
    Oracle RAC 10gR1 to 10gR2. This patch should be installed on all nodes
    before installing Oracle 10.2.0.1 software. Be sure to download the 10gR2
    version of Patch 6718715.

    Software Version and other details
    AIX
    5.3 TL10 SP5 or newer, must include fix for APAR IZ89268
    6.1 TL4 SP7 or newer, must include fix for APAR IZ87768
    VIOS 2.2.0.10 FP24 SP1 or newer
    PowerHA 6.1 SP3 or newer
    RSCT
    For AIX 5.3, RSCT 2.4.12.0 or newer
    For AIX 6.1, RSCT 2.5.4.0 or newer
    Oracle
    10gR2
    Oracle 10gR2 patchset 10.2.0.5 or newer is required.
    Patch 6718715 should be installed on all nodes before installing Oracle
    10.2.0.5 software. Be sure to download the 10gR2 version of Patch
    6718715.

Speak Your Mind

TEL/電話+86 13764045638
Email service@parnassusdata.com
QQ 47079569